hdu 1155 Bungee Jumping 解题报告 代码超精简

 http://acm.hdu.edu.cn/showproblem.php?pid=1155

Problem Description
Once again, James Bond is fleeing from some evil people who want to see him dead. Fortunately, he has left a bungee rope on a nearby highway bridge which he can use to escape from his enemies. His plan is to attach one end of the rope to the bridge, the other end of the rope to his body and jump off the bridge. At the moment he reaches the ground, he will cut the rope, jump into his car and be gone.

Unfortunately, he had not had enough time to calculate whether the bungee rope has the right length, so it is not clear at all what is going to happen when he jumps off the bridge. There are three possible scenarios:The rope is too short (or too strong), and James Bond will never reach the ground.The rope is too long (or too weak), and James Bond will be going too fast when he touches the ground. Even for a special agent, this can be very dangerous. You may assume that if he collides at a speed of more than 10 m/s, he will not survive the impact.The rope’s length and strength are good. James Bond touches the ground at a comfortable speed and can escape.As his employer, you would like to know whether James Bond survives or whether you should place a job ad for the soon-to-be vacant position in the local newspaper. Your physicists claim that:The force with which James is pulled towards the earth is9.81 * w,where w is his weight in kilograms and 9.81 is the Earth acceleration in meters over squared seconds.Mr. Bond falls freely until the rope tautens. Then the force with which the bungee rope pulls him back into the sky depends on the current length of the rope and is k * Δl,where Δl is the difference between the rope’s current length and its nominal, unexpanded length, and k is a rope-specific constant.Given the rope’s strength k, the nominal length of the rope l in meters, the height of the bridge s in meters, and James Bond’s body weight w, you have to determine what is going to happen to our hero. For all your calculations, you may assume that James Bond is a point at the end of the rope and the rope has no mass. You may further assume that k, l, s, and w are non-negative and that s < 200.
The input contains several test cases, one test case per line. Each test case consists of four floating-point numbers (k, l, s, and w) that describe the situation. Depending on what is going to happen, your program must print “Stuck in the air.”, “Killed by the impact.”, or “James Bond survives.”. Input is terminated by a line containing four 0s, this line should not be processed.

Sample Input
350 20 30 75
375 20 30 75
400 20 30 75
425 20 30 75
450 20 30 75
400 20 30 50
400 20 30 80
400 20 30 85
0 0 0 0

Sample Output
Killed by the impact.
James Bond survives.
James Bond survives.
James Bond survives.
Stuck in the air.
Stuck in the air.
James Bond survives.
Killed by the impact.


代码

#include<stdio.h>
void main()
{
    double k,l,s,w;
    while(scanf("%lf%lf%lf%lf",&k,&l,&s,&w),k||l||s||w)
        if(s<l||w*9.81*s-k*(s-l)*(s-l)/2>=0){
            if(2*9.81*s-(s>=l)*k*(s-l)*(s-l)/w<=100)
                puts("James Bond survives.");
            else
                puts("Killed by the impact.");
        }
        else
            puts("Stuck in the air.");
}

分析
当s<l时肯定能到地面
v^2=2*g*s;
当s>l且能到地面
即s>=l且0.5*w*v^2=w*g*s-k/2*(s-l)^2>0时
v^2=2*g*s-k*(s-l)^2/e。
综合两个就是

if(s<l||w*9.81*s-k*(s-l)*(s-l)/2>=0){
    v^2=2*g*s-k*(s-l)^2/e;
    判断是否为安全速度;
}
else
    到不了地面;

直接判断2*9.81*s-(s>=l)*k*(s-l)*(s-l)/w<=100看他是否能安全逃脱

发表评论?

0 条评论。

发表评论